Совместимость BuddyPress и WordPress

Совместимость BuddyPress и WordPress

BuddyPress лучше всего работает с последними версиями WordPress, но специально для тех, кто не любит или не может обновляться, команда BuddyPress поддерживает совместимость со старым WordPress. В основном это 4 или 5 мажорных релизов (которые 4.5, 4.4, 4.3 и так далее). Процесс пересмотра совместимого WordPress происходит следующим образом:

  • в начале каждого цикла разработки BuddyPress смотрят на даты релизов WordPress, и если прошло больше года после какого-то релиза – есть вероятность, что откажутся от его поддержки
  • если процентное соотшение использования WordPress меньше 5% – это эта версия является очень хорошим кандидатом на прекращение поддержки.

Что подразумевается под фразой “BuddyPress поддерживает какую-то версию WordPress”:

  • BuddyPress работает без ошибок на этой версии WP
  • автоматические тесты прогоняются при каждом изменении кода на этой версии WP
  • если в BuddyPress появляется какой-то функционал, для работы которого нужна одна из последних версий WP, то при работе на версии WP меньше необходимой, этот функционал у BuddyPress должен автоматически и незаметно (без ошибок) отключаться

Новая совместимость BuddyPress и WordPress

WordPress 4.1 был выпущен чуть больше года назад, и у него доля рынка – 5,9%. У 4,0 все гораздо хуже (более полутора лет и 4%). Поэтому:

BuddyPress 2.6 будет работать без ошибок на WordPress 4.1+.

BuddyPress 2.5 продолжает работать без ошибок на WordPress 3.9+.


А какая версия WordPress стоит на вашем сайте с BuddyPress?

Добавить комментарий

Ваш адрес email не будет опубликован.