BuddyPress 2.8 и WordPress 4.3

BuddyPress 2.8 будет официально поддерживать WordPress версии 4.3 и выше. Такое решение приняли на вчерашнем митинге разработчики BuddyPress.

Причин для этого несколько:

  • WordPress 4.2 уже старый (значительно больше года)
  • доля версии 4.2 составляет менее 5%

Оба этих факта являются критериями, по которым проект BuddyPress отказывается от старых версий WordPress. Все правила можно посмотреть вот тут.

Это означает, что на форуме не будут осуществлять поддержку для такой старой версии, и код специально для совместимости с ней тоже не будут писать, и автоматические тесты не будут прогоняться с WordPress 4.2.

Соответствующий тикет я создал (и его уже закрыли) в Trac: #7350.

Для истории – поддержка минимальных версий WordPress:

BuddyPress 2.5WordPress 3.9+
BuddyPress 2.6WordPress 4.1+
BuddyPress 2.7WordPress 4.2+
BuddyPress 2.8WordPress 4.3+

Добавить комментарий

Ваш адрес email не будет опубликован.